Cellular Partner Outage - Canada
Incident Report for DroneMobile
Resolved
This incident has been resolved.
Posted Jun 28, 2024 - 07:37 PDT
Identified
Our cellular partner in Canada is experiencing service disruptions that are beyond our control. Users in the US are not impacted by this service disruption.
Posted Jun 27, 2024 - 14:08 PDT