6-17-2026

Incident Report for DroneMobile

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 20:11 PDT

Investigating

We are currently investigating an issue impacting delivery of commands to devices
Posted Jun 17, 2026 - 19:48 PDT
This incident affected: Drone Command Handler (Drone API, Drone X1).