10-20-2025

Incident Report for DroneMobile

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:59 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 14:49 PDT

Update

Our public cloud provider is still actively working to mitigate this issue with urgency and while we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation.
Posted Oct 20, 2025 - 09:49 PDT

Identified

An issue with an external vendor is impacting Drone services
Posted Oct 20, 2025 - 07:04 PDT
This incident affected: Drone Command Handler (Drone API, Drone DR3x00,DR5400/DR6400, Drone X1) and Drone Web Site Status (Drone Accounts, Drone Activation Portal).